aboutsummaryrefslogtreecommitdiffstats
path: root/src/wrap/perl-xs/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'src/wrap/perl-xs/Makefile.PL')
-rw-r--r--src/wrap/perl-xs/Makefile.PL29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/wrap/perl-xs/Makefile.PL b/src/wrap/perl-xs/Makefile.PL
new file mode 100644
index 000000000..d35c99168
--- /dev/null
+++ b/src/wrap/perl-xs/Makefile.PL
@@ -0,0 +1,29 @@
+use ExtUtils::MakeMaker;
+
+my ($cc, $cflags, $lids);
+if ( $^O eq 'MSWin32' )
+{
+# $cflags = '';
+# $libs = ':nosearch -lgdi32 -llibeay32';
+}
+else
+{
+ $cc = 'g++';
+ $cflags = '-fexceptions ' . qx( botan-config --cflags );
+ $libs = qx( botan-config --libs );
+}
+
+WriteMakefile(
+ 'NAME' => 'Botan',
+ 'DISTNAME' => 'Botan-XS',
+ 'VERSION_FROM' => 'Botan.pm', # finds $VERSION
+ 'XSOPT' => '-C++',
+ 'CC' => $cc,
+ 'LD' => '$(CC)',
+ 'CCFLAGS' => $cflags,
+ 'LIBS' => [ $libs ],
+ 'OPTIMIZE' => '-g',
+# 'clean' => {
+# 'FILES' => 'neco.p12 rnd',
+# },
+);