aboutsummaryrefslogtreecommitdiffstats
path: root/src/wrap/perl-xs/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'src/wrap/perl-xs/Makefile.PL')
-rw-r--r--src/wrap/perl-xs/Makefile.PL29
1 files changed, 0 insertions, 29 deletions
diff --git a/src/wrap/perl-xs/Makefile.PL b/src/wrap/perl-xs/Makefile.PL
deleted file mode 100644
index 5a3276aec..000000000
--- a/src/wrap/perl-xs/Makefile.PL
+++ /dev/null
@@ -1,29 +0,0 @@
-use ExtUtils::MakeMaker;
-
-my ($cc, $cflags, $lids);
-if ( $^O eq 'MSWin32' )
-{
-# $cflags = '';
-# $libs = ':nosearch -lgdi32 -llibeay32';
-}
-else
-{
- $cc = 'g++';
- $cflags = $Config::Config{ccflags} . ' -Wno-write-strings -fexceptions ' . qx( botan-config-1.11 --cflags );
- $libs = qx( botan-config --libs );
-}
-
-WriteMakefile(
- 'NAME' => 'Botan',
- 'DISTNAME' => 'Botan-XS',
- 'VERSION_FROM' => 'Botan.pm', # finds $VERSION
- 'XSOPT' => '-C++',
- 'CC' => $cc,
- 'LD' => '$(CC)',
- 'CCFLAGS' => $cflags,
- 'LIBS' => [ $libs ],
- 'OPTIMIZE' => '-g',
-# 'clean' => {
-# 'FILES' => 'neco.p12 rnd',
-# },
-);