aboutsummaryrefslogtreecommitdiffstats
path: root/src/wrap/perl-xs/Makefile.PL
diff options
context:
space:
mode:
authorlloyd <[email protected]>2009-10-28 22:55:12 +0000
committerlloyd <[email protected]>2009-10-28 22:55:12 +0000
commit3623be3fd05d890309cc3da4b3a1e319e357df65 (patch)
tree34ca43fcf8a7007cc01a3919f63e9ab6763cb673 /src/wrap/perl-xs/Makefile.PL
parentfc1e61500e77fcabe67e6d2607810c1ba071bbdd (diff)
parent9462f875b13a321f42a127166d49670ca04afcde (diff)
propagate from branch 'net.randombit.botan.1_8' (head 3158f8272a3582dd44dfb771665eb71f7d005339)
to branch 'net.randombit.botan' (head bf629b13dd132b263e76a72b7eca0f7e4ab19aac)
Diffstat (limited to 'src/wrap/perl-xs/Makefile.PL')
-rw-r--r--src/wrap/perl-xs/Makefile.PL29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/wrap/perl-xs/Makefile.PL b/src/wrap/perl-xs/Makefile.PL
new file mode 100644
index 000000000..46317e72b
--- /dev/null
+++ b/src/wrap/perl-xs/Makefile.PL
@@ -0,0 +1,29 @@
+use ExtUtils::MakeMaker;
+
+my ($cc, $cflags, $lids);
+if ( $^O eq 'MSWin32' )
+{
+# $cflags = '';
+# $libs = ':nosearch -lgdi32 -llibeay32';
+}
+else
+{
+ $cc = 'g++';
+ $cflags = '-Wno-write-strings -fexceptions ' . qx( botan-config --cflags );
+ $libs = qx( botan-config --libs );
+}
+
+WriteMakefile(
+ 'NAME' => 'Botan',
+ 'DISTNAME' => 'Botan-XS',
+ 'VERSION_FROM' => 'Botan.pm', # finds $VERSION
+ 'XSOPT' => '-C++',
+ 'CC' => $cc,
+ 'LD' => '$(CC)',
+ 'CCFLAGS' => $cflags,
+ 'LIBS' => [ $libs ],
+ 'OPTIMIZE' => '-g',
+# 'clean' => {
+# 'FILES' => 'neco.p12 rnd',
+# },
+);