aboutsummaryrefslogtreecommitdiffstats
path: root/misc/xs/Makefile.PL
diff options
context:
space:
mode:
authorlloyd <[email protected]>2008-09-17 22:31:08 +0000
committerlloyd <[email protected]>2008-09-17 22:31:08 +0000
commitbd5bc359e18058ca5cbb4b8ae404b76652b63699 (patch)
treedbba21a01b8a89cbf13344aeb104fe3f9de5ebb5 /misc/xs/Makefile.PL
parent02bef612526398febe10a40b80777d4d13544f40 (diff)
Add Botan-XS 0.01, a Botan module for Perl5, by Vaclav Ovsik <[email protected]>
This has been sitting around on my hard drive for a long time, and may have bit-rotten due to changes in Botan and/or Perl (I haven't tested it yet). Sorry about the wait Vaclav.
Diffstat (limited to 'misc/xs/Makefile.PL')
-rw-r--r--misc/xs/Makefile.PL29
1 files changed, 29 insertions, 0 deletions
diff --git a/misc/xs/Makefile.PL b/misc/xs/Makefile.PL
new file mode 100644
index 000000000..d35c99168
--- /dev/null
+++ b/misc/xs/Makefile.PL
@@ -0,0 +1,29 @@
+use ExtUtils::MakeMaker;
+
+my ($cc, $cflags, $lids);
+if ( $^O eq 'MSWin32' )
+{
+# $cflags = '';
+# $libs = ':nosearch -lgdi32 -llibeay32';
+}
+else
+{
+ $cc = 'g++';
+ $cflags = '-fexceptions ' . qx( botan-config --cflags );
+ $libs = qx( botan-config --libs );
+}
+
+WriteMakefile(
+ 'NAME' => 'Botan',
+ 'DISTNAME' => 'Botan-XS',
+ 'VERSION_FROM' => 'Botan.pm', # finds $VERSION
+ 'XSOPT' => '-C++',
+ 'CC' => $cc,
+ 'LD' => '$(CC)',
+ 'CCFLAGS' => $cflags,
+ 'LIBS' => [ $libs ],
+ 'OPTIMIZE' => '-g',
+# 'clean' => {
+# 'FILES' => 'neco.p12 rnd',
+# },
+);