summaryrefslogtreecommitdiffstats
path: root/gtk/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gtk/src/Makefile.am')
-rw-r--r--gtk/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gtk/src/Makefile.am b/gtk/src/Makefile.am
index 5dbecd50a..52be4d1c2 100644
--- a/gtk/src/Makefile.am
+++ b/gtk/src/Makefile.am
@@ -149,7 +149,7 @@ uninstall-local:
fi; \
rm -f $(DESTDIR)/$(datadir)/icons/hicolor/$$SIZE/apps/$$FILE; \
done
- @-if test -d "$(DESTDIR)/$(datadir)"; then \
+ @-if test -z "$(DESTDIR)"; then \
echo "Updating Gtk icon cache."; \
$(gtk_update_icon_cache); \
else \
@@ -171,7 +171,7 @@ install-data-local:
mkdir -p $(DESTDIR)/$(datadir)/icons/hicolor/$$SIZE/apps/; \
$(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)/$(datadir)/icons/hicolor/$$SIZE/apps/$$FILE; \
done
- @-if test -d "$(DESTDIR)/$(datadir)"; then \
+ @-if test -z "$(DESTDIR)"; then \
echo "Updating Gtk icon cache."; \
$(gtk_update_icon_cache); \
else \