summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 0323214f2..423923bf4 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -45,6 +45,10 @@ else
AC_SUBST(HB_DIR, '$(top_srcdir)/'"..")
fi
+AC_ARG_ENABLE(dl,
+ AS_HELP_STRING([--enable-dl], [enable libdl]),
+ use_libdl=yes, use_libdl=no)
+
AC_ARG_ENABLE(gst,
AS_HELP_STRING([--enable-gst], [enable gstreamer on Win32]),
w32_gst=yes, w32_gst=no)
@@ -103,6 +107,14 @@ AM_CONDITIONAL([MINGW], [test "x$mingw_flag" = "xyes"])
PKG_CHECK_MODULES(GHB, [$GHB_PACKAGES])
+case $host in
+ *-*-mingw*)
+ if test "x$use_libdl" = "xyes" ; then
+ GHB_LIBS="$GHB_LIBS -ldl"
+ fi
+ ;;
+esac
+
AC_SUBST(GHB_CFLAGS)
AC_SUBST(GHB_LIBS)