summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 4c75f4a90..43dc81942 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -52,6 +52,10 @@ else
AC_SUBST(HB_DIR, '$(top_srcdir)/'"..")
fi
+AC_ARG_ENABLE(flatpak,
+ AS_HELP_STRING([--enable-flatpak], [enable QSV encoder]),
+ use_flatpak=yes, use_flatpak=no)
+
AC_ARG_ENABLE(dl,
AS_HELP_STRING([--enable-dl], [enable libdl]),
use_libdl=yes, use_libdl=no)
@@ -183,6 +187,8 @@ case $host in
;;
esac
+AM_CONDITIONAL([GHB_FLATPAK], [test "$use_flatpak" = "yes"])
+
if test "x$use_fdk_aac" = "xyes" ; then
HB_LIBS="$HB_LIBS -lfdk-aac"
fi