summaryrefslogtreecommitdiffstats
path: root/pkg/linux/debian/rules.artful
diff options
context:
space:
mode:
authorJohn Stebbins <[email protected]>2017-10-18 10:23:41 -0700
committerJohn Stebbins <[email protected]>2017-10-18 10:23:41 -0700
commitca0af3c0723b55b6e6ba3b7717080a3ebfe284d4 (patch)
tree49848815df3dee68beaa273f2b890cb52df1e988 /pkg/linux/debian/rules.artful
parent51dfb87c4cb69875663404a69b9acf4713859ddd (diff)
LinGui: add Ubuntu 17.10 (artful) to snapshots
Final 17.10 release is tomorrow...
Diffstat (limited to 'pkg/linux/debian/rules.artful')
-rwxr-xr-xpkg/linux/debian/rules.artful85
1 files changed, 85 insertions, 0 deletions
diff --git a/pkg/linux/debian/rules.artful b/pkg/linux/debian/rules.artful
new file mode 100755
index 000000000..bab615cfe
--- /dev/null
+++ b/pkg/linux/debian/rules.artful
@@ -0,0 +1,85 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
+CROSS= --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+else
+CROSS= --build $(DEB_BUILD_GNU_TYPE)
+endif
+
+PKGDESTDIR = ../
+CONFIGURE = ./configure
+BUILDDIR = build
+FORCEVERSION =
+
+$(BUILDDIR)/GNUmakefile: $(CONFIGURE)
+ dh_testdir
+ unset CFLAGS; unset CPPLAGS; unset CXXLAGS; $(CONFIGURE) --disable-gtk-update-checks --prefix=/usr
+
+build: $(BUILDDIR)/GNUmakefile
+ dh_testdir
+ #We must build both the main project and the GTK project
+ unset CFLAGS ; unset CPPLAGS ; unset CXXLAGS; $(MAKE) -C $(BUILDDIR)
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_installdirs
+ $(MAKE) -C $(BUILDDIR) DESTDIR=$(CURDIR)/debian/tmp install
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs -i
+ dh_installdocs -i
+ dh_install --sourcedir=debian/tmp -i
+ dh_icons -i
+ dh_link -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i $(FORCEVERSION)
+ dh_md5sums -i
+ dh_builddeb --destdir=$(PKGDESTDIR) -i
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_install --sourcedir=debian/tmp -a
+ dh_installchangelogs -a
+ dh_installdocs -a
+ dh_installexamples -a
+ dh_installman -a
+ dh_link -a
+ dh_icons -a
+ dh_strip -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a $(FORCEVERSION)
+ dh_md5sums -a
+ dh_builddeb -a --destdir=$(PKGDESTDIR) -- -Zbzip2
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install