summaryrefslogtreecommitdiffstats
path: root/gtk/src/Makefile.am
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2014-03-17 19:15:58 +0000
committerjstebbins <[email protected]>2014-03-17 19:15:58 +0000
commitd51206be7b8317d495885e20b846feb93463217d (patch)
treeaa7c42c80d25ec72a789102453988cd5de142e0b /gtk/src/Makefile.am
parentd6b1b9c0b12f4142357988f8eaffb3005ca81331 (diff)
LinGui: svg'ify several icons
and enable embedding of svg icons in the binary. git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@6118 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/src/Makefile.am')
-rw-r--r--gtk/src/Makefile.am35
1 files changed, 12 insertions, 23 deletions
diff --git a/gtk/src/Makefile.am b/gtk/src/Makefile.am
index 28b3a196e..c816e46d7 100644
--- a/gtk/src/Makefile.am
+++ b/gtk/src/Makefile.am
@@ -11,33 +11,24 @@ icons = \
hb-icon.16.png
icons_dep = \
- hb-activity.32.png \
- hb-activity.64.png \
- hb-add-queue.32.png \
- hb-add-queue.64.png \
- hb-canceled.16.png \
+ hb-icon.svg \
+ hb-start.svg \
+ hb-pause.svg \
+ hb-stop.svg \
+ hb-add-queue.svg \
+ hb-showqueue.svg \
+ hb-picture.svg \
+ hb-activity.svg \
+ hb-source.svg \
+ hb-remove.svg \
hb-complete.16.png \
hb-status.32.png \
hb-status-empty.32.png \
- hb-icon.128.png \
- hb-icon.64.png \
- hb-pause.32.png \
- hb-pause.64.png \
- hb-start.32.png \
- hb-start.64.png \
hb-pref.32.png \
- hb-showqueue.32.png \
- hb-showqueue.64.png \
- hb-remove.24.png \
- hb-remove.48.png \
hb-queue-job.16.png \
hb-queue-pass1.16.png \
hb-queue-pass2.16.png \
hb-queue-subtitle.16.png \
- hb-source.32.png \
- hb-source.64.png \
- hb-stop.32.png \
- hb-stop.64.png \
hb-working0.16.png \
hb-working1.16.png \
hb-working2.16.png \
@@ -81,8 +72,6 @@ ghb_SOURCES = \
preview.c \
icons.c \
icons.h \
- icon_tools.c \
- icon_tools.h \
values.c \
values.h \
appcast.c \
@@ -134,10 +123,10 @@ CREATE_RES.c = \
CREATE_RES.c.o = $(patsubst %.c,%-native.o,$(CREATE_RES.c))
create_resources: $(CREATE_RES.c.o)
- $(CC_FOR_BUILD) -o $@ $^ $(GHB_TOOLS_LIBS)
+ $(CC_FOR_BUILD) -g -o $@ $^ $(GHB_TOOLS_LIBS)
$(CREATE_RES.c.o): %-native.o: %.c
- $(CC_FOR_BUILD) $(GHB_TOOLS_CFLAGS) -c -o $@ $<
+ $(CC_FOR_BUILD) $(GHB_TOOLS_CFLAGS) -g -c -o $@ $<
ghbcellrenderertext.$(OBJEXT): marshalers.h