summaryrefslogtreecommitdiffstats
path: root/gtk/src/Makefile.am
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2010-09-08 16:51:59 +0000
committerjstebbins <[email protected]>2010-09-08 16:51:59 +0000
commita007891bf9f7e53d3705c51b5b41f9e56a144031 (patch)
treeb7a532c24a458d549afb0174c374e631b896a46e /gtk/src/Makefile.am
parent772c3574758e9bc29cb76bbc86343cf9ad5ddd71 (diff)
Add Bluray support
Unencrypted BD directory trees only. Doesn't support iso images. Also, no PGS subtitle support yet. Chapters and angles are supported. Adds a new contrib libbluray. Adds new option to hb_scan() for duration of short titles to filter. This applies to BD and DVD multi-title scans only. Does not apply to any single title scans. Fixes memory leak during scan. hb_buffer_close() was not freeing all buffers in a chain of buffers passed to it. git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@3510 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/src/Makefile.am')
-rw-r--r--gtk/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gtk/src/Makefile.am b/gtk/src/Makefile.am
index 12d23b11e..42d5d7f78 100644
--- a/gtk/src/Makefile.am
+++ b/gtk/src/Makefile.am
@@ -5,13 +5,13 @@ HB_LIBS= \
-lhb -la52 -lmkv -lavformat -lavcodec -lavutil -ldca -ldvdnav -ldvdread \
-lfaac -lmp3lame -lmpeg2 -lvorbis -lvorbisenc -logg -lsamplerate \
-lx264 -lmp4v2 -lswscale -ltheora -lfaad -lz \
- -lbz2 -liberty -lpthreadGC2
+ -lbz2 -liberty -lpthreadGC2 -lbluray
else
HB_LIBS= \
-lhb -la52 -lmkv -lavformat -lavcodec -lavutil -ldca -ldvdnav -ldvdread \
-lfaac -lmp3lame -lmpeg2 -lvorbis -lvorbisenc -logg -lsamplerate \
-lx264 -lmp4v2 -lswscale -ltheora -lfaad -lz \
- -lbz2 -lpthread
+ -lbz2 -lpthread -lbluray
endif
icons = \