summaryrefslogtreecommitdiffstats
path: root/gtk/src/Makefile.am
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2008-10-15 18:39:45 +0000
committerjstebbins <[email protected]>2008-10-15 18:39:45 +0000
commit8079d10b0c22f7a7270828829286cb9947b8a99d (patch)
treee03881798433f18d5903bc102c13d48102d7eafa /gtk/src/Makefile.am
parent5aab68603cb6b50a0a08c48497174f53ad771caf (diff)
LinGui: nested presets
new nested builtins. user can create custom folders and drag n drop custom presets. updated mac to linux presets plist translation tool to handle new format git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@1835 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/src/Makefile.am')
-rw-r--r--gtk/src/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/gtk/src/Makefile.am b/gtk/src/Makefile.am
index 7d4d1d3ba..41881d090 100644
--- a/gtk/src/Makefile.am
+++ b/gtk/src/Makefile.am
@@ -73,7 +73,7 @@ AM_CFLAGS =\
-g
bin_PROGRAMS = ghb
-noinst_PROGRAMS = makewidgetdeps quotestring create_resources
+noinst_PROGRAMS = makewidgetdeps quotestring create_resources preset_xlat
BUILT_SOURCES = HandBrakeCLI
@@ -145,8 +145,19 @@ create_resources_SOURCES = \
create_resources_LDADD = $(GHBTOOLS_LIBS)
+preset_xlat_SOURCES = \
+ preset_xlat.c \
+ plist.c \
+ plist.h \
+ values.c \
+ values.h
+
+preset_xlat_LDADD = $(GHBTOOLS_LIBS)
+
quotestring_SOURCES = quotestring.c
+dumbell: preset_xlat
+
resources.c: resource_data.h
resource_data.h: quotestring resources.plist