summaryrefslogtreecommitdiffstats
path: root/gtk/src/Makefile.am
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2010-06-15 16:21:22 +0000
committerjstebbins <[email protected]>2010-06-15 16:21:22 +0000
commit24425e7e50a80a43bc074935ece579697c451dff (patch)
tree5615b19138b2ed9272b016928b1a810877342b9f /gtk/src/Makefile.am
parent542ebf7e5cdc4a5f6c3ac34c56265004ec67affa (diff)
LinGui: changes to resource preprocessor
During the build, I was compiling tools for preprocessing and packaging the gui description xml, preset defaults, widget dependencies, and icons. The resulting resource_data.h file gets compiled into the binary. These tools are now implemented in python. This eliminates the need to compile the tools which caused complications when cross compiling. This work was actually done many months ago. But all the distributions I wanted to support didn't have the libplist python module. Now they all do. git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@3382 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/src/Makefile.am')
-rw-r--r--gtk/src/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/gtk/src/Makefile.am b/gtk/src/Makefile.am
index 52be4d1c2..38412ea18 100644
--- a/gtk/src/Makefile.am
+++ b/gtk/src/Makefile.am
@@ -117,15 +117,15 @@ ghb_DEPENDENCIES = $(HB_DIR)/libhb/libhb.a
resources.o: resource_data.h
-resource_data.h: quotestring resources.plist
- ./quotestring resources.plist resource_data.h
+resource_data.h: resources.plist
+ python $(srcdir)/quotestring.py resources.plist resource_data.h
-widget_reverse.deps: widgetdeps
-widget.deps: widgetdeps
- ./widgetdeps
+widget_reverse.deps: makedeps.py
+widget.deps: makedeps.py
+ python $(srcdir)/makedeps.py
-resources.plist: create_resources resources.list $(icons_dep) internal_defaults.xml standard_presets.xml ghb.ui widget.deps widget_reverse.deps
- ./create_resources -I$(srcdir) $(srcdir)/resources.list resources.plist
+resources.plist: create_resources.py resources.list $(icons_dep) internal_defaults.xml standard_presets.xml ghb.ui widget.deps widget_reverse.deps
+ python $(srcdir)/create_resources.py -I$(srcdir) $(srcdir)/resources.list resources.plist
ghbcellrenderertext.$(OBJEXT): marshalers.h