summaryrefslogtreecommitdiffstats
path: root/gtk/src/Makefile.am
diff options
context:
space:
mode:
authorJohn Stebbins <[email protected]>2017-12-23 16:13:56 -0800
committerJohn Stebbins <[email protected]>2017-12-23 16:13:56 -0800
commitd8b6c1c4355e0e20c586d028c7be483ba1f7eb57 (patch)
tree975e82e437e32f5439afa487da4f97f877eac17a /gtk/src/Makefile.am
parentc7b76d7e236cc07a87e3b6a3b6e15579aa459fe9 (diff)
LinGui: add support for alternate icons
GTK will use lower res icons if available for lower res screens.
Diffstat (limited to 'gtk/src/Makefile.am')
-rw-r--r--gtk/src/Makefile.am42
1 files changed, 30 insertions, 12 deletions
diff --git a/gtk/src/Makefile.am b/gtk/src/Makefile.am
index 6378b90ce..9468dd616 100644
--- a/gtk/src/Makefile.am
+++ b/gtk/src/Makefile.am
@@ -4,18 +4,36 @@ icons = \
hb-icon.svg
icons_dep = \
- hb-icon.svg \
- hb-start.svg \
- hb-pause.svg \
- hb-stop.svg \
- hb-add-queue.svg \
- hb-showqueue.svg \
- hb-picture.svg \
- hb-activity.svg \
- hb-source.svg \
- hb-remove.svg \
- hb-edit.svg \
- hb-complete.svg
+ icons/24x24/apps/hb-remove.png \
+ icons/32x32/apps/hb-source.png \
+ icons/32x32/apps/hb-picture.png \
+ icons/32x32/apps/hb-add-queue.png \
+ icons/32x32/apps/hb-showqueue.png \
+ icons/32x32/apps/hb-activity.png \
+ icons/32x32/apps/hb-start.png \
+ icons/32x32/apps/hb-stop.png \
+ icons/32x32/apps/hb-pause.png \
+ icons/48x48/apps/hb-remove.png \
+ icons/64x64/apps/hb-source.png \
+ icons/64x64/apps/hb-picture.png \
+ icons/64x64/apps/hb-add-queue.png \
+ icons/64x64/apps/hb-showqueue.png \
+ icons/64x64/apps/hb-activity.png \
+ icons/64x64/apps/hb-start.png \
+ icons/64x64/apps/hb-stop.png \
+ icons/64x64/apps/hb-pause.png \
+ icons/scalable/apps/hb-source.svg \
+ icons/scalable/apps/hb-picture.svg \
+ icons/scalable/apps/hb-add-queue.svg \
+ icons/scalable/apps/hb-showqueue.svg \
+ icons/scalable/apps/hb-activity.svg \
+ icons/scalable/apps/hb-start.svg \
+ icons/scalable/apps/hb-stop.svg \
+ icons/scalable/apps/hb-pause.svg \
+ icons/scalable/apps/hb-remove.svg \
+ icons/scalable/apps/hb-complete.svg \
+ icons/scalable/apps/hb-edit.svg \
+ icons/scalable/apps/hb-icon.svg
if GHB_FLATPAK
icons += fr.handbrake.ghb.svg