summaryrefslogtreecommitdiffstats
path: root/gtk/src/Makefile.am
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2008-08-07 18:48:04 +0000
committerjstebbins <[email protected]>2008-08-07 18:48:04 +0000
commit138aa5d206ae6ee6296948367de807089f414f6a (patch)
treeb1ccc1fc88c1039ce7746f7d91cd15f9905c4542 /gtk/src/Makefile.am
parent752317f0446985db9179dcc975f10652400af589 (diff)
LinGui: fix problem with install target of make
not all directories were being created. needed for installing in alternate destination where all the system dirs may not exist git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@1615 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/src/Makefile.am')
-rw-r--r--gtk/src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/gtk/src/Makefile.am b/gtk/src/Makefile.am
index 16b55a354..f55fe9470 100644
--- a/gtk/src/Makefile.am
+++ b/gtk/src/Makefile.am
@@ -123,4 +123,5 @@ install-data-local:
echo "*** Icon cache not updated. After install, run this:"; \
echo "*** $(gtk_update_icon_cache)"; \
fi
+ mkdir -p $(DESTDIR)/$(datadir)/applications/; \
$(INSTALL_DATA) $(srcdir)/$(hb_menu) $(DESTDIR)/$(datadir)/applications/$(hb_menu)