summaryrefslogtreecommitdiffstats
path: root/gtk/src/Makefile.am
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2009-08-24 17:32:22 +0000
committerjstebbins <[email protected]>2009-08-24 17:32:22 +0000
commit2752e26db58d8304e3ddb03a9b95c4f9af7bf5fa (patch)
tree20bcb6484190356bc65bd0448cd4ca3f7f36ba80 /gtk/src/Makefile.am
parent9e43a26a870845acafbeff92f62db3609c48e37c (diff)
build system: some changes that simplify things for packaging tools
- Add DESTDIR to install path for HandBrakeCLI - Modify linux packaging rules for deb and rpm packages to use DESTDIR - lingui: only update icon cache during install if DESTDIR is not set - patch out the hardcoded install path for m4 macros in libdvdread and libdvdnav when uid==0 git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@2774 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/src/Makefile.am')
-rw-r--r--gtk/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gtk/src/Makefile.am b/gtk/src/Makefile.am
index 5dbecd50a..52be4d1c2 100644
--- a/gtk/src/Makefile.am
+++ b/gtk/src/Makefile.am
@@ -149,7 +149,7 @@ uninstall-local:
fi; \
rm -f $(DESTDIR)/$(datadir)/icons/hicolor/$$SIZE/apps/$$FILE; \
done
- @-if test -d "$(DESTDIR)/$(datadir)"; then \
+ @-if test -z "$(DESTDIR)"; then \
echo "Updating Gtk icon cache."; \
$(gtk_update_icon_cache); \
else \
@@ -171,7 +171,7 @@ install-data-local:
mkdir -p $(DESTDIR)/$(datadir)/icons/hicolor/$$SIZE/apps/; \
$(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)/$(datadir)/icons/hicolor/$$SIZE/apps/$$FILE; \
done
- @-if test -d "$(DESTDIR)/$(datadir)"; then \
+ @-if test -z "$(DESTDIR)"; then \
echo "Updating Gtk icon cache."; \
$(gtk_update_icon_cache); \
else \