summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorlameventanas <[email protected]>2015-12-04 15:00:31 +0900
committerlameventanas <[email protected]>2015-12-04 15:00:31 +0900
commitcb4c7c4f52475a3ccc323b5547a6d1dd65c012af (patch)
tree56e15ba143286dcdcaa0a2407cfc575df11a992d /gtk/configure.ac
parent46e641c8c55fd45b644d511eb436086ea3f62ee9 (diff)
Fix bashism in autoconf script that leads to build failure unless bash is /bin/sh.
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 98649ad13..0cf85a8b1 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -162,30 +162,30 @@ HB_LIBS="-lhandbrake -lavresample -lavformat -lavcodec -lavutil -ldvdnav -ldvdre
case $host in
*-*-mingw*)
if test "x$use_libdl" = "xyes" ; then
- HB_LIBS+=" -ldl"
+ HB_LIBS="$HB_LIBS -ldl"
fi
if test "x$use_libpthread" = "xyes" ; then
- HB_LIBS+=" -lpthread"
+ HB_LIBS="$HB_LIBS -lpthread"
else
- HB_LIBS+=" -lpthreadGC2"
+ HB_LIBS="$HB_LIBS -lpthreadGC2"
fi
- HB_LIBS+=" -lregex -luuid"
+ HB_LIBS="$HB_LIBS -lregex -luuid"
;;
*)
- HB_LIBS+=" -ldl -lpthread"
+ HB_LIBS="$HB_LIBS -ldl -lpthread"
;;
esac
if test "x$use_fdk_aac" = "xyes" ; then
- HB_LIBS+=" -lfdk-aac"
+ HB_LIBS="$HB_LIBS -lfdk-aac"
fi
if test "x$use_x265" = "xyes" ; then
- HB_LIBS+=" -lx265"
+ HB_LIBS="$HB_LIBS -lx265"
fi
if test "x$use_qsv" = "xyes" ; then
- HB_LIBS+=" -lmfx"
+ HB_LIBS="$HB_LIBS -lmfx"
fi
AC_SUBST(HB_LIBS)