summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorJohn Stebbins <[email protected]>2016-08-30 09:51:05 -0700
committerGitHub <[email protected]>2016-08-30 09:51:05 -0700
commita464833a790f44f061f9de42a88f64e49156d422 (patch)
tree4ae1aeeb0d1e98640efe55c5f9db94a329f0de9f /gtk/configure.ac
parentaed230d055ce0e64dfc0a41e401a7a3e7e7fd7bb (diff)
LinGui: Add flatpak support (#231)
* LinGui: add --flatpak configure option For building a linux flatpak bundle * LinGui: add rules to build flatpak repo and bundles * LinGui: add flatpak compatible icon * LinGui: add flatpak compatible desktop file * LinGui: add flatpak appdata xml * pkg: disable building LinGui when creating cli flatpak * pkg: clean flatpak build cache when updating source package * pkg: fix source package build dependencies Fixes errors when the git ref being packaged changes and you have not manually deleted stage and pkg build directories.
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 42a4ed581..3b690b21f 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -107,10 +107,9 @@ case $host in
*)
case "$host_os" in
linux*)
- pkg_gudev="gudev-1.0"
;;
esac
- GHB_PACKAGES="gthread-2.0 gio-2.0 libnotify dbus-glib-1 gmodule-2.0 $pkg_gudev"
+ GHB_PACKAGES="gthread-2.0 gio-2.0 libnotify dbus-glib-1 gmodule-2.0"
mingw_flag=no
;;
esac
@@ -120,6 +119,14 @@ GHB_PACKAGES="gtk+-3.0 $GHB_PACKAGES"
GST1_MODULES="gstreamer-1.0 gstreamer-video-1.0 gstreamer-audio-1.0 gstreamer-pbutils-1.0"
+pkg_gudev="gudev-1.0"
+PKG_CHECK_MODULES(Gudev, [$pkg_gudev], have_gudev=yes, have_gudev=no)
+if test "x$have_gudev" = "xyes" ; then
+ GHB_PACKAGES="$GHB_PACKAGES $pkg_gudev"
+ CXXFLAGS="$CXXFLAGS -D_HAVE_GUDEV"
+ CFLAGS="$CFLAGS -D_HAVE_GUDEV"
+fi
+
if test "x$gst_disable" = "xno" ; then
PKG_CHECK_MODULES(GStreamer1, [$GST1_MODULES], use_gst1=yes, use_gst1=no)
if test "x$use_gst1" = "xyes" ; then