summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2009-08-11 17:41:04 +0000
committerjstebbins <[email protected]>2009-08-11 17:41:04 +0000
commit12cb08b853843552d2373e7d342ec88527561d05 (patch)
tree7e2c98230366e321035fe04322204ba3f878073e /gtk/configure.ac
parentfd88b574a2d980491a693e6d8747669a8507a031 (diff)
LinGui: fix some compatibility issues
- use new gnome session manager when available for shutdown and pm inhibit - fall back to old gnome power manager when sm is not available - fix webkit build error on Ubuntu 8.04 TLS git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@2761 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index a7d900831..1aaea79eb 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -69,14 +69,14 @@ AM_PROG_LIBTOOL
case $host in
*-*-mingw*)
if test "x$w32_gst" = "xyes" ; then
- GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage webkit-1.0"
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage"
else
GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gio-2.0"
fi
mingw_flag=yes
;;
*)
- GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage webkit-1.0 libnotify"
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage libnotify"
mingw_flag=no
;;
esac
@@ -86,6 +86,17 @@ if test "x$w32_gst" = "xyes" -o "x$mingw_flag" != "xyes" ; then
CFLAGS="$CFLAGS -D_ENABLE_GST"
fi
+PKG_CHECK_MODULES(OldWebKitGtk, WebKitGtk, old_webkit=yes, old_webkit=no)
+if test "x$old_webkit" = "xyes" ; then
+ if test "x$mingw_flag" = "xno" ; then
+ GHB_PACKAGES="$GHB_PACKAGES WebKitGtk"
+ CXXFLAGS="$CXXFLAGS -D_OLD_WEBKIT"
+ CFLAGS="$CFLAGS -D_OLD_WEBKIT"
+ fi
+else
+ GHB_PACKAGES="$GHB_PACKAGES webkit-1.0"
+fi
+
AM_CONDITIONAL([MINGW], [test "x$mingw_flag" = "xyes"])
PKG_CHECK_MODULES(GHB, [$GHB_PACKAGES])