summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorJohn Stebbins <[email protected]>2016-10-19 10:36:17 -0700
committerJohn Stebbins <[email protected]>2016-10-19 10:36:17 -0700
commit1b93f994e3394ff9136a726df16492b8d97d9cd0 (patch)
treef57af75beb7273fbc80292a323737dd82ae61560 /gtk/configure.ac
parent19b0ddf3ff846337738a2398459656bcd8f66fe9 (diff)
LinGui: fix installation of desktop file
Don't install flatpak desktop file when not building a flatpak. This was causing duplicate icons in some distros.
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 4c75f4a90..43dc81942 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -52,6 +52,10 @@ else
AC_SUBST(HB_DIR, '$(top_srcdir)/'"..")
fi
+AC_ARG_ENABLE(flatpak,
+ AS_HELP_STRING([--enable-flatpak], [enable QSV encoder]),
+ use_flatpak=yes, use_flatpak=no)
+
AC_ARG_ENABLE(dl,
AS_HELP_STRING([--enable-dl], [enable libdl]),
use_libdl=yes, use_libdl=no)
@@ -183,6 +187,8 @@ case $host in
;;
esac
+AM_CONDITIONAL([GHB_FLATPAK], [test "$use_flatpak" = "yes"])
+
if test "x$use_fdk_aac" = "xyes" ; then
HB_LIBS="$HB_LIBS -lfdk-aac"
fi