summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2012-10-05 22:40:03 +0000
committerjstebbins <[email protected]>2012-10-05 22:40:03 +0000
commit13e4fc1725bc45b9f59adcba9228f0554dc90e35 (patch)
tree17b9c8e99e293111a46d135d15badbbbf51d0175 /gtk/configure.ac
parent657a2ce1106c975f15d1bde54dda386c15d51db2 (diff)
LinGui: use more system libs
use system libs for fontconfig, freetype, libxml2, libass, libogg, libvorbis, libtheora, and libsamplerate update build dependencies for ubuntu packages update documentation to reflect new build dependencies fix a problem with hb.h conflict with harfbuzz/hb.h git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@5001 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index b4965c48f..dbe15f747 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -36,21 +36,18 @@ AC_ARG_WITH(hb,
if test $hb_PATHSET = 1 ; then
case ${with_hb} in
/*)
- CXXFLAGS="$CXXFLAGS -I$with_hb/libhb -I$with_hb/contrib/include"
- CFLAGS="$CFLAGS -I$with_hb/libhb -I$with_hb/contrib/include"
+ HBINC="-I$with_hb/libhb -I$with_hb/contrib/include"
LDFLAGS="$LDFLAGS -L$with_hb/libhb -L$with_hb/contrib/lib"
AC_SUBST(HB_DIR, "$with_hb")
;;
*)
- CXXFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"$with_hb/libhb "'-I$(top_srcdir)/'"$with_hb/contrib/include"
- CFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"$with_hb/libhb "'-I$(top_srcdir)/'"$with_hb/contrib/include"
+ HBINC='-I$(top_srcdir)/'"$with_hb/libhb "'-I$(top_srcdir)/'"$with_hb/contrib/include"
LDFLAGS="$LDFLAGS "'-L$(top_srcdir)/'"$with_hb/libhb "'-L$(top_srcdir)/'"$with_hb/contrib/lib"
AC_SUBST(HB_DIR, '$(top_srcdir)/'"$with_hb")
;;
esac
else
- CXXFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"../libhb "'-I$(top_srcdir)/'"../contrib/include"
- CFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"../libhb "'-I$(top_srcdir)/'"../contrib/include"
+ HBINC='-I$(top_srcdir)/'"../libhb "'-I$(top_srcdir)/'"../contrib/include"
LDFLAGS="$LDFLAGS "'-L$(top_srcdir)/'"../libhb "'-L$(top_srcdir)/'"../contrib/lib"
AC_SUBST(HB_DIR, '$(top_srcdir)/'"..")
fi
@@ -141,6 +138,8 @@ if test "x$have_appind" = "xyes" ; then
fi
PKG_CHECK_MODULES(GHB, [$GHB_PACKAGES])
+GHB_CFLAGS="$HBINC $GHB_CFLAGS"
+
AC_PATH_PROG(BUILD_PKG_CONFIG, pkg-config, no)
if test x"$BUILD_PKG_CONFIG" = x"no"; then
AC_MSG_ERROR([You need to install pkg-config])