summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2010-05-23 15:38:21 +0000
committerjstebbins <[email protected]>2010-05-23 15:38:21 +0000
commit28658486daa5cd3e7a58edb3539885422889c44f (patch)
tree22bd3d2a80d5443584ece6d769cd7d41c53cdfaa /gtk/configure.ac
parenta28717d0b3d41674934d6e0e24ee70344576fb1e (diff)
add ability to probe for existance of headers and libraries to configure.py
use this to check for system versions of bz2 z pthreadGC2 iberty and dl when building with mingw. solves a problem with conflicts when building on fedora with a full standard install of their mingw packages. git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@3316 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 0323214f2..423923bf4 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -45,6 +45,10 @@ else
AC_SUBST(HB_DIR, '$(top_srcdir)/'"..")
fi
+AC_ARG_ENABLE(dl,
+ AS_HELP_STRING([--enable-dl], [enable libdl]),
+ use_libdl=yes, use_libdl=no)
+
AC_ARG_ENABLE(gst,
AS_HELP_STRING([--enable-gst], [enable gstreamer on Win32]),
w32_gst=yes, w32_gst=no)
@@ -103,6 +107,14 @@ AM_CONDITIONAL([MINGW], [test "x$mingw_flag" = "xyes"])
PKG_CHECK_MODULES(GHB, [$GHB_PACKAGES])
+case $host in
+ *-*-mingw*)
+ if test "x$use_libdl" = "xyes" ; then
+ GHB_LIBS="$GHB_LIBS -ldl"
+ fi
+ ;;
+esac
+
AC_SUBST(GHB_CFLAGS)
AC_SUBST(GHB_LIBS)