summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorJohn Stebbins <[email protected]>2017-08-04 16:57:23 -0700
committerJohn Stebbins <[email protected]>2017-08-04 17:00:13 -0700
commit9d98250279e5337d3083bd8d33e38d1f88669c9a (patch)
tree1cdba54fd5c6889874da6b0532aacce54d9fce8f /gtk/configure.ac
parenteb1d99a074e06b336aa1ac0dcad0fa192ac4240e (diff)
LinGui: rework audio/subtitle tabs gtk < 3.16
Add support for older gtk versions
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 93ef3cf20..ebe42e142 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -157,8 +157,10 @@ else
CFLAGS="$CFLAGS -D_NO_UPDATE_CHECK"
fi
+PKG_CHECK_MODULES([GHB_GTK_3_16], [gtk+-3.0 >= 3.16], [HAVE_GTK_316=1], [HAVE_GTK_316=0])
PKG_CHECK_MODULES([GHB_GTK_3_14], [gtk+-3.0 >= 3.14], [HAVE_GTK_314=1], [HAVE_GTK_314=0])
PKG_CHECK_MODULES([GHB_GTK_3_12], [gtk+-3.0 >= 3.12], [HAVE_GTK_312=1], [HAVE_GTK_312=0])
+AM_CONDITIONAL([GHB_GTK_3_16], [test "$HAVE_GTK_316" -eq 1])
AM_CONDITIONAL([GHB_GTK_3_14], [test "$HAVE_GTK_314" -eq 1])
AM_CONDITIONAL([GHB_GTK_3_12], [test "$HAVE_GTK_312" -eq 1])