summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2011-06-20 15:58:36 +0000
committerjstebbins <[email protected]>2011-06-20 15:58:36 +0000
commit5c75564427bbb893c4444af1d8c7304ce5343dcf (patch)
treed615017f668919154355ed469f0b6a8205b106a4 /gtk/configure.ac
parent2625067e6983ff27d139352178662926020d37d3 (diff)
LinGui: Add status tray icon support for Ubuntu 11.04
Ubuntu disables GtkStatusIcon support in Unity and instead uses a new API called AppIndicator. So this adds support for appindicator when it is detected by configure. git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@4067 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index e811fe2b7..d2db300c4 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -128,6 +128,12 @@ fi
AM_CONDITIONAL([MINGW], [test "x$mingw_flag" = "xyes"])
+PKG_CHECK_MODULES(libappindicator, appindicator-0.1, have_appind=yes, have_appind=no)
+if test "x$have_appind" = "xyes" ; then
+ GHB_PACKAGES="$GHB_PACKAGES appindicator-0.1"
+ CXXFLAGS="$CXXFLAGS -D_USE_APP_IND"
+ CFLAGS="$CFLAGS -D_USE_APP_IND"
+fi
PKG_CHECK_MODULES(GHB, [$GHB_PACKAGES])
AC_PATH_PROG(BUILD_PKG_CONFIG, pkg-config, no)