summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorRodeo <[email protected]>2012-06-18 21:11:48 +0000
committerRodeo <[email protected]>2012-06-18 21:11:48 +0000
commitfc3e44b2ba28772fa559d39bd57b7a595a83292f (patch)
tree738449c393dcd8da6edf6881e53353b35e5c47b8 /gtk/configure.ac
parent510564b19b5a6d7ac77091cd02ec9c557941399f (diff)
libhb: drop HB_INPUT_CH_LAYOUT_*
AV_CH_LAYOUT_* works for us, and as its usage becomes more widespread in libhb, translating between the two formats gets increasingly tedious. git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@4754 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 94219c32d..b4965c48f 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -36,21 +36,21 @@ AC_ARG_WITH(hb,
if test $hb_PATHSET = 1 ; then
case ${with_hb} in
/*)
- CXXFLAGS="$CXXFLAGS -I$with_hb/libhb"
- CFLAGS="$CFLAGS -I$with_hb/libhb"
+ CXXFLAGS="$CXXFLAGS -I$with_hb/libhb -I$with_hb/contrib/include"
+ CFLAGS="$CFLAGS -I$with_hb/libhb -I$with_hb/contrib/include"
LDFLAGS="$LDFLAGS -L$with_hb/libhb -L$with_hb/contrib/lib"
AC_SUBST(HB_DIR, "$with_hb")
;;
*)
- CXXFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"$with_hb/libhb"
- CFLAGS="$CFLAGS "'-I$(top_srcdir)/'"$with_hb/libhb"
+ CXXFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"$with_hb/libhb "'-I$(top_srcdir)/'"$with_hb/contrib/include"
+ CFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"$with_hb/libhb "'-I$(top_srcdir)/'"$with_hb/contrib/include"
LDFLAGS="$LDFLAGS "'-L$(top_srcdir)/'"$with_hb/libhb "'-L$(top_srcdir)/'"$with_hb/contrib/lib"
AC_SUBST(HB_DIR, '$(top_srcdir)/'"$with_hb")
;;
esac
else
- CXXFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"../libhb"
- CFLAGS="$CFLAGS "'-I$(top_srcdir)/'"../libhb"
+ CXXFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"../libhb "'-I$(top_srcdir)/'"../contrib/include"
+ CFLAGS="$CXXFLAGS "'-I$(top_srcdir)/'"../libhb "'-I$(top_srcdir)/'"../contrib/include"
LDFLAGS="$LDFLAGS "'-L$(top_srcdir)/'"../libhb "'-L$(top_srcdir)/'"../contrib/lib"
AC_SUBST(HB_DIR, '$(top_srcdir)/'"..")
fi