summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2009-06-20 18:08:06 +0000
committerjstebbins <[email protected]>2009-06-20 18:08:06 +0000
commit0865bab7662ff6e7e831705c5b0f2aa6916f855b (patch)
tree7f6d9422e04dffc7ed5cd8b1ca7e6e016b679ad0 /gtk/configure.ac
parent2c92194ddde3710dba84abea10aa123b835a8d4f (diff)
LinGui: make status icon code backwards compatible to gtk 2.10
There's a new status icon api in 2.16 that is not backwards compatible. The depricated interface is broken in 2.16, so ifdef the code to use older api only when older gtk versions are used. git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@2589 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 3e7ae4a90..a7d900831 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -69,14 +69,14 @@ AM_PROG_LIBTOOL
case $host in
*-*-mingw*)
if test "x$w32_gst" = "xyes" ; then
- GHB_PACKAGES="gtk+-2.0 >= 2.8 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage webkit-1.0"
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage webkit-1.0"
else
- GHB_PACKAGES="gtk+-2.0 >= 2.8 gthread-2.0 gio-2.0"
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gio-2.0"
fi
mingw_flag=yes
;;
*)
- GHB_PACKAGES="gtk+-2.0 >= 2.8 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage webkit-1.0 libnotify"
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage webkit-1.0 libnotify"
mingw_flag=no
;;
esac