summaryrefslogtreecommitdiffstats
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorjstebbins <[email protected]>2012-06-07 23:18:40 +0000
committerjstebbins <[email protected]>2012-06-07 23:18:40 +0000
commit42f3324742a8aa77e65202e8549f5239e3d12d3a (patch)
tree2235e63d65e6b65eac413b7e1f1bb93ee8792efa /gtk/configure.ac
parent156f480430db82fb3dd20bbdab26abc2665a9fb1 (diff)
Portability patches
gudev is only available on linux, so ifdef it out on all other systems. also add some definitions to the make system for generic gnu and freebsd systems. git-svn-id: svn://svn.handbrake.fr/HandBrake/trunk@4717 b64f7644-9d1e-0410-96f1-a4d463321fa5
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index d2db300c4..94219c32d 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -94,10 +94,15 @@ case $host in
mingw_flag=yes
;;
*)
+ case "$host_os" in
+ linux*)
+ pkg_gudev="gudev-1.0"
+ ;;
+ esac
if test "x$gst_disable" = "xyes" ; then
- GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gio-2.0 libnotify dbus-glib-1 gudev-1.0"
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gio-2.0 libnotify dbus-glib-1 $pkg_gudev"
else
- GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 libnotify dbus-glib-1 gudev-1.0"
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 libnotify dbus-glib-1 $pkg_gudev"
fi
mingw_flag=no
;;